Wickr Me outage - sign in and message send effected
Incident Report for Wickr
Resolved
All issues have been confirmed resolved. Please reach out to support@wickr.com if you need help!
Posted Feb 19, 2021 - 13:49 CST
Monitoring
Fixes have been applied and we are monitoring as users begin to reconnect.
Posted Feb 19, 2021 - 11:21 CST
Update
Wickr Me may be down for up to 90 minutes while we continue to add additional fixes.
Posted Feb 19, 2021 - 10:33 CST
Update
We are continuing to work on a fix for this issue.
Posted Feb 19, 2021 - 09:25 CST
Identified
We have identified an issue with Wickr Me and are working to restore services. Thank you for your patience!
Posted Feb 19, 2021 - 09:16 CST
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..