Wickr Me - Intermittent Message Send Delays
Incident Report for Wickr
Resolved
If anyone continues to see issues sending from Wickr Me please reach out to support@wickr.com.

Thank you!
Posted Apr 09, 2021 - 10:34 CDT
Investigating
We've received reports that some users are seeing slower than normal message send times. We are currently looking into this. Please email support@wickr.com if you are seeing this issue on your device.
Posted Apr 09, 2021 - 09:24 CDT
This incident affected: Wickr Me.