Wickr Pro and Me calling issues
Incident Report for Wickr
Resolved
Calling has been restored for both Pro and Me. If you still have any issues please reach out to support@wickr.com.
Posted Feb 22, 2021 - 10:14 CST
Investigating
We've had reports of calls failing on both Wickr Me and Wickr Pro. We are currently investigating.
Posted Feb 22, 2021 - 09:24 CST
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023. and Wickr Pro // AWS Wickr.