Unable to upload files
Incident Report for Wickr
Resolved
This was resolved as of 12:56pm PST, and it was an issue with AWS S3.

Thank you!
Posted over 1 year ago. Jan 24, 2018 - 18:03 CST
Investigating
We are currently investigating an issue when trying to upload files to Wickr Me and Wickr Pro.

Thank you for your patience as we get this fixed!
Posted over 1 year ago. Jan 24, 2018 - 14:52 CST