Login issues with Wickr Pro
Incident Report for Wickr
Resolved
This incident has been resolved.
Posted Jul 13, 2020 - 12:55 CDT
Update
The issues have been resolved. Please let support@wickr.com know if you see any continuing problems.
Posted Jul 13, 2020 - 12:54 CDT
Investigating
We are receiving reports of users being logged out, as well as users who are unable to sign in on Wickr Pro.

We are currently investigating.
Posted Jul 13, 2020 - 09:58 CDT
This incident affected: Wickr Pro // AWS Wickr.