Wickr Me - Degraded Performance
Incident Report for Wickr
Resolved
Wickr Me is back up and running as expected.
Posted Oct 02, 2019 - 09:58 CDT
Investigating
We are currently investigating issues sending, receiving, and maintaining connection to our backend services.
Posted Oct 02, 2019 - 08:50 CDT
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..