Wickr Me - Send message issues
Incident Report for Wickr
Resolved
The service is now back to normal. If there is any trouble sending messages, please restart your client and try again. If you continue to see issues please reach out to us at support@wickr.com! Thank you!
Posted Mar 10, 2022 - 12:19 CST
Identified
We are currently working to resolve the reported send issues in Wickr Me. Thank you for your patience!
Posted Mar 10, 2022 - 11:25 CST
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..