Wickr Me - Send Messages Issues
Incident Report for Wickr
Resolved
We sincerely apologize for the delays, however Wickr Me should be fully operational once again! If you continue to see issues please restart your Wickr Me app, or you can reach out to support@wickr.com!
Posted Nov 02, 2021 - 13:44 CDT
Monitoring
Working on adjustments to fix the situation
Posted Oct 31, 2021 - 11:43 CDT
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..