Degraded Wickr Me Performance
Incident Report for Wickr
Resolved
We have resolved the issues sending and receiving Wickr Me messages. We will continue to work to improve the service.
Posted Feb 08, 2022 - 14:03 CST
Identified
We are currently working through an issue sending and receiving Wickr Me messages.
Posted Feb 08, 2022 - 11:38 CST
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..