Wickr Pro Invitation Delays
Incident Report for Wickr
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 10:15 CST
Update
The invitation issue has been resolved.
Posted Feb 26, 2020 - 10:15 CST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2020 - 10:15 CST
Investigating
We are currently having issues with our email provider when sending new invitations to Wickr Pro users. We're digging in and will have an update very soon!

This only affects invitations. All other functionality is working as intended.
Posted Feb 26, 2020 - 10:01 CST
This incident affected: Wickr Pro // AWS Wickr.