Wickr Me - Service Degredation
Incident Report for Wickr
Resolved
All issues have been resolved.
Posted Jul 02, 2019 - 15:47 CDT
Investigating
We've heard and seen reports of Wickr Me users unable to sign in or send messages. We're currently looking into the cause.
Posted Jul 02, 2019 - 14:33 CDT
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..