Wickr Me - Message Send Failures
Incident Report for Wickr
Resolved
This incident has been resolved. If you continue to see issues please reach out to support@wickr.com.
Posted Mar 31, 2021 - 13:11 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2021 - 11:44 CDT
Investigating
We are currently investigating this issue.
Posted Mar 31, 2021 - 11:19 CDT
This incident affected: Wickr Me.