Wickr Me - Maintenance
Incident Report for Wickr
Resolved
The Wickr Me maintenance has completed successfully.

Thank you!
Posted over 1 year ago. Nov 10, 2017 - 01:06 CST
Monitoring
Wickr Me infrastructure will be upgraded tonight, Thursday November 9th.

There will unfortunately be downtime, however we will do our best to keep it as short as possible.

Thank you for your patience!
Posted over 1 year ago. Nov 09, 2017 - 22:43 CST