Wickr Admin Panel - Unavailable
Incident Report for Wickr
Resolved
The Wickr Admin Panel sign in issue has been resolved. If you continue to have issues signing in, please reach out to support@wickr.com.

Thank you!
Posted Apr 18, 2022 - 15:22 CDT
Identified
We are aware of an issue signing into the Admin Panel for Wickr Pro. We are working to restore access as soon as possible and will update here once service is restored.
Posted Apr 18, 2022 - 15:02 CDT
This incident affected: Wickr Pro // AWS Wickr.