Slow message sending
Incident Report for Wickr
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 10:03 CST
Identified
We are aware of an issue with message send performance on Wickr Me. We'll be adding increased capacity to the infrastructure tonight to resolve.

Thank you for your patience and for all of our new users!
Posted Feb 11, 2021 - 13:50 CST
This incident affected: Wickr Me - Discontinued as of 31-Dec-2023..