Ongoing issues with file uploads
Incident Report for Wickr
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 09:04 CST
Identified
The issue with file uploads has been identified and a fix has been implemented. We will be working to restore access to files uploaded in the past 48 hours.
Posted Nov 20, 2020 - 18:30 CST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2020 - 18:26 CST
Investigating
We are currently investigating issues around sharing files in Wickr Me and Wickr Pro.

Thank you for your patience as we get this fixed!
Posted Nov 20, 2020 - 15:21 CST
This incident affected: Wickr Me and Wickr Pro.